Support Article
SLA queue items move to broken queue with exceptions
Summary
User invokes an activity to create a different case. In the Service Level Agreement (SLA) activity, an add cover activity is invoked to create a child case. However, the SLA queue items move to the broken queue with the exceptions.
Error Messages
cannot be null or blank. page: Declare_pyDisplay.pyDisplay. Details: Invalid value for aReference passed to pega.pegarules.data.internal.clipboard.ClipboardPageImpl.getProperty
pega.pegarules.pub.clipboard.InvalidParameterException: cannot be null or blank. page: Declare_pyDisplay.pyDisplay. Details: Invalid value for aReference passed to pega.pegarules.data.internal.clipboard.ClipboardPageImpl.getProperty(String, char)
at pega.pegarules.data.internal.clipboard.ClipboardPageImpl.getProperty(ClipboardPageImpl.java:729) ~[prprivate.jar:?]
at pega.pegarules.data.internal.clipboard.ClipboardPageImpl.getProperty(ClipboardPageImpl.java:679) ~[prprivate.jar:?]
at pega.pegarules.data.internal.clipboard.ClipboardPropertyImpl.getPageValue(ClipboardPropertyImpl.java:2239) ~[prprivate.jar:?]
at pega.pegarules.session.internal.mgmt.autostreams.HarnessUIBuilder.isSDM(HarnessUIBuilder.java:555) ~[prprivate.jar:?]
at pega.pegarules.session.internal.mgmt.autostreams.HarnessUIBuilder.setTemplatingStatus(HarnessUIBuilder.java:888) ~[prprivate.jar:?]
Steps to Reproduce
Run the flow configured with the assignment level SLA.
Root Cause
SLA goal activity creates a child case using the AddCovered activity which internally invokes the SDM() method of HarnessUIBuilder.java. In this method, getPortalName() is invoked to retrieve the portal name which is an empty value.
Resolution
Apply HFix-54280.
Published August 19, 2019 - Updated December 2, 2021
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