Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

SMA authentication does not work

SA-67250

Summary



Authentication does not work despite enabling System Management Application (SMA) authentication.


Error Messages



Not Applicable


Steps to Reproduce



Update the web.xml  file with the PegaDiagnosticUser role.


Root Cause



The web.xml file was updated incorrectly in the user environment.


Resolution



Perform the following local-change:

Update the web.xml file with the below code.

<security-constraint>
<web-resource-collection>
<web-resource-name>System Management Application - DB utility
Application </web-resource-name>
<description>secure all urls for this application</description>
<url-pattern>/*</url-pattern>
<http-method>GET</http-method>
<http-method>POST</http-method>
</web-resource-collection>
<auth-constraint>
<role-name>PegaDiagnosticUser</role-name>
</auth-constraint>
</security-constraint>

<login-config>
<auth-method>BASIC</auth-method>
<realm-name>PegaRULES</realm-name>
</login-config>

<security-role>
<role-name>PegaDiagnosticUser</role-name>
</security-role>

Published December 2, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us