Support Article
SMA authentication does not work
SA-67250
Summary
Authentication does not work despite enabling System Management Application (SMA) authentication.
Error Messages
Not Applicable
Steps to Reproduce
Update the web.xml file with the PegaDiagnosticUser role.
Root Cause
The web.xml file was updated incorrectly in the user environment.
Resolution
Perform the following local-change:
Update the web.xml file with the below code.
<security-constraint>
<web-resource-collection>
<web-resource-name>System Management Application - DB utility
Application </web-resource-name>
<description>secure all urls for this application</description>
<url-pattern>/*</url-pattern>
<http-method>GET</http-method>
<http-method>POST</http-method>
</web-resource-collection>
<auth-constraint>
<role-name>PegaDiagnosticUser</role-name>
</auth-constraint>
</security-constraint>
<login-config>
<auth-method>BASIC</auth-method>
<realm-name>PegaRULES</realm-name>
</login-config>
<security-role>
<role-name>PegaDiagnosticUser</role-name>
</security-role>
Published December 2, 2019 - Updated October 8, 2020
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