Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

SMA does not connect to node when SSL certs install

SA-7597

Summary



SMA does not connect to Pega node after SSL certificates are installed on the server side.

Error Messages



com.pega.jmx.ui.util.JMXClientException: Fail to instantiate WASJMXConnector
Failed to get mbean server connection
SMA ERROR: Failed to create admin client
CWWMC0016E: The system cannot create a SOAP connector to connect to host <host> at port <port>.

Steps to Reproduce



Install SSL certificates at the Websphere NDM (Network Deployment Manager) level.

Root Cause



The root cause of the issue is due to Websphere 7 not validating self sign certificate in the trust.p12 at the NDM level.


Resolution



This issue is resolved by installing the certificate at the node level.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us