Support Article
SMA fails with JMXClientException
SA-30223
Summary
When a user tries to connect to a node in the System Management Application (SMA), it fails with the below error on screen.
This issue is specific to the user. No changes have been taken place in the server side. User is not facing this issue when application accessed from other systems.
Error Messages
SMA error com.pega.jmx.ui.util.JMXClientException: Session expired, please login in a new browser window
java.lang.NullPointerException
com.pega.jmx.ui.action.PerformDefaultOpAction.execute(PerformDefaultOpAction.java:107)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java
Steps to Reproduce
1) Open the SMA.
2) Try to connect to a node.
Root Cause
Issue with Internet Explorer 11 browser settings. Application when tested using fiddler, the requests were not hitting the server and also not being recorded in fiddler traces.
Resolution
As the issue is specific to the user and there are no changes taken place in server side.
User is able to access application from other systems. Issue gets resolved by reinstalling and installing the Internet Explorer 11 and make changes by referring to:
https://pdn.pega.com/support-articles/sma-behavior-incorrect-ie11-compatibility-mode
Published November 17, 2016 - Updated October 8, 2020
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