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Support Article

SMA is not working on PRPC6.3 on Jboss5.1

SA-13026

Summary



Installation is done for PPRC 6.3 on Jboss application server 5.1 and user tries to set up the System Management Application (SMA), but it stops working after adding a local node.


Error Messages



Cannot connect to the server with specified settings
No MBean server found with PegaRULES MBeans registered.


Steps to Reproduce



Not Applicable.


Root Cause



The root cause of this problem is Jboss requires a JMX port for retrieving the PRPC host data via MBean. The jmx port specified in the run.conf runtime paramaters should be used while configuring SMA.


Resolution



This issue is resolved by making the following local-change:

Provide the same port as in run.conf parameters on the JMX URL field while configuring SMA.

 

Published August 13, 2015 - Updated December 2, 2021

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