Support Article
SMA stops working as node IDs change after restarting JVM
SA-73448
Summary
System Management Application (SMA) stops working as the node IDs change after restarting the JVM.
Error Messages
com.pega.jmx.ui.util.JMXClientException: No MBeans found for the node your_pega_node
Steps to Reproduce
Restart the JVM.
Root Cause
The node ID is dependent on the Pega system name, temporary directory location and hostname, by default. If any of these change, the node ID will change.
Resolution
Perform the following local-change:
Set the node ID statically by using the below JVM argument:
-Didentification.nodeid=<node_id>
Published February 20, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.