Support Article
SMA, wrong count of scheduled items on System Queue Management
SA-20468
Summary
User reported that, in the System Management Application (SMA), the count of scheduled items on the System Queue Management page is different than what is shown in the below queues tables in the database:
PR_CEP_EVENTS_QUEUE
PR_SYS_QUEUES
PR_SYS_QUEUE_AUTOTEST
PR_SYS_QUEUE_COL_POP
PR_SYS_QUEUE_EXECREQ_CONN
PR_SYS_QUEUE_EXECREQ_SVC
PR_SYS_QUEUE_SLA
PR_SYS_QUEUE_STARTFLOWS
PR_SYS_WORKINDEXER_QUEUE
Error Messages
Not Application.
Steps to Reproduce
Use following tables to get count.
PR_CEP_EVENTS_QUEUE
PR_SYS_QUEUES
PR_SYS_QUEUE_AUTOTEST
PR_SYS_QUEUE_COL_POP
PR_SYS_QUEUE_EXECREQ_CONN
PR_SYS_QUEUE_EXECREQ_SVC
PR_SYS_QUEUE_SLA
PR_SYS_QUEUE_STARTFLOWS
PR_SYS_WORKINDEXER_QUEUE
Root Cause
The issue was that bloating of the BLOB and the invalidate indexes.
Resolution
Use the below queries to shrink the BLOBs to resolve the behavior:
PZPVSTREAM from PR_SYS_QUEUES table.
alter table pr_sys_queues enable row movement;
alter table pr_sys_queues shrink space;
alter table pr_sys_queues disable row movement;
Also the index:
alter index pr_sys_queues_index1 rebuild;
Published March 5, 2016 - Updated October 8, 2020
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