Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Smart Dispute ChargebackTransactionAmount rounded incorrectly

SA-4456

Summary



The ChargebackTransactionAmount is getting rounded incorrectly to a whole number.

Error Messages



no error message


Steps to Reproduce



Create a dispute on a transaction where the Billing Currency is JPY (exponent = 0) and Transaction Currency is anything else (example GBP).
After submitting the dispute the  Chargeback transaction Amount is getting improperly rounded.


Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules.



Resolution



Provided HFix-10408 to che customer
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us