Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Smart Dispute does not generate DB2Zos DDL

SA-4649

Summary



Admin completed upgrade to Pega 7.1.5 and is now attempting to upgrade the Smart Dispute for Issuers Framework version 7.11 on db2zos database.  DDL provided with the media is for DB2 UDB not DB2 ZOS.   Tried to use the import wizard to download the DDL needed to give to his DBA to apply. In the DDL there are calls to Admin_Cmd stored procedure with no command parameter specified. 

CALL SYSPROC.ADMIN_CMD(?) 

The DDL generated is for db2 udb and not for db2 zos.


Error Messages



ALTER TABLE PegaData.pa_contact ALTER COLUMN Logins SET NOT NULL
@
CALL SYSPROC.ADMIN_CMD(?)


Steps to Reproduce



Use the import wizard to import the ApplicationBundle jar file and download the DDL to manual have DBA apply.


Root Cause



This framework was not certified on db2zos.  

Resolution



Framework team has now certified on this database platform and provided needed DDL scripts to do a new installation and also to upgrade from the Smart Dispute for Issuers version 6.1sp2.

Open a service request (SR) to request the needed DDL.  Follow instructions to customize and apply DDL to your environment and then continue with the installation procedure as outlined in installation guide.
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us