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Support Article

SMS is sent twice on running a campaign

SA-91502

Summary

SMS is sent twice on running a campaign with a customer and an offer.


Error Messages


 

Not Applicable


Steps to Reproduce

  1. Create a strategy with an offer import
  2. Create an offer flow with a Send SMS shape
  3. Create an offer flow with a Wait shape 
  4. Create a segment with a user
  5. Create a campaign with all the artefacts
  6. Run the campaign


Root Cause



A software use or operation error. The CustomerData dataflow contains a merge operation with the main Customer dataset. The main Customer dataset does not contain primary keys on the table. As a result, the Extract, Transform and Load (ETL) process inserts duplicate records.

Resolution



Make the following change to the operating environment:
  1. Remove duplicate records from the Customer table
  2. Add a primary key 

Published October 16, 2019 - Updated December 2, 2021

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