Support Article
SMS is sent twice on running a campaign
SA-91502
Summary
SMS is sent twice on running a campaign with a customer and an offer.
Error Messages
Not Applicable
Steps to Reproduce
- Create a strategy with an offer import
- Create an offer flow with a Send SMS shape
- Create an offer flow with a Wait shape
- Create a segment with a user
- Create a campaign with all the artefacts
- Run the campaign
Root Cause
A software use or operation error. The CustomerData dataflow contains a merge operation with the main Customer dataset. The main Customer dataset does not contain primary keys on the table. As a result, the Extract, Transform and Load (ETL) process inserts duplicate records.
Resolution
Make the following change to the operating environment:
- Remove duplicate records from the Customer table
- Add a primary key
Published October 16, 2019 - Updated December 2, 2021
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