Support Article
SMTP-Port-Configuration not always passsed
SA-3182
Summary
We have some scenarios, where we need to pass a different SMTP-Port then the common port 25 for outgoing E-Mail / Correspondences.
Even after deployment of HFIX-9638 we face some situations where the port is not correctly passed.
On deeper investigation we observed that the HFIX-9638 does not cover all scearnios where smtp-port needs to be set; be observed issues in "PegaApp-Work-.AppCorrInternalEmailUpdate" (PegaAppCor:05-02-01) and PegaApp-Work-.AppCorrUpdate (05-02-01).
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The application was recently upgraded.
The previous versions were PRPC 5.2 with the corresponding SI-Framework.
Currently we are using PRPC 6.1SP2 with corresponding SI-Framework.
Error Messages
Session runs into timeout, due to the default-port is used.
Steps to Reproduce
We are using FlowActions for Correspondence-Creation. One of those are "PegaCommBank-Corr-EzEmail" instances.
We face trouble on sending thsoe E-Mails with a non-default-port (timeout).
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules.
We found 2 Smart Investigate rule which are just not passing the SMTP port parameter.
Resolution
SI rules are not passing on the SMTP port and need to be corrected.
We found 2 new rules:
• PegaApp-Doc.FinStepTxnCorrUpdate
• PegaApp-Work-.FinCorrResendUpdate
Hfix-10260 is fixing this along with these 2 others rules:
RULE-OBJ-ACTIVITY PEGAAPP-WORK- APPCORRUPDATE #20140926T052707.637 GMT
RULE-OBJ-ACTIVITY PEGAAPP-DOC FINSTEPTXNCORRUPDATE #20141029T064903.279 GMT
Published January 31, 2016 - Updated October 8, 2020
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