Support Article
SOAP Service Failed error upon login
SA-38434
Summary
Connect SOAP rules starts failing after few hours of operations.
The application users are getting the error **Soap Service Failed when trying to log in, as an external authentication service through a SOAP call is performed.
The nature of the issue is sporadic with respect to the different users.
Error Messages
On login screen **SOAP Service Failed
Steps to Reproduce
Attempt to log into the Pega application which has an external authentication service configured through a SOAP call.
Root Cause
An issue in the custom application rule.
In the Production box the access group xyz:unauthenticated is used by the browser requestors type for external authentication and this access group is having the Pega-IntSvcs:06-02-25 in the Production RuleSets.
This RuleSet is above the Pega-RULES:06-02-25.
So during rule resolution, the nvokeaxis2, which is present in Pega-IntSvcs is picked and this is wrong.
The logger class Rule_Obj_Activity.InvokeAxis2.Rule_Connect_SOAP.Action confirmed that the steps does not match with the InvokeAxis2 activity present in the Pega-IntegrationEngine
Resolution
Perform the following local-change:
Remove the ruleset Pega-IntSvcs:06-02-25 from the access group used by the browser requestors type for external authentication.
Optional steps:
1. Follow the PDN article:
https://pdn.pega.com/troubleshooting-soap-connection-errors-many-tcp-sockets-closewait-state-red-hat-enterprise-linux
2. Install HFix-6324 and HFix-6912.
3. And set the following are Dynamic System Settings:
- Pega-IntegrationEngine axis2_max_connections 2000
- Pega-IntegrationEngine axis2_max_hostconnections 200
User might have to fine adjust the above two DSS to lower values.
Published July 6, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.