Support Article
Some alerts are not written to the alert log file
SA-18079
Summary
Some alerts are not written to the alert log file even though the alert buffer is set to maximum size.
Error Messages
Not Applicable
Steps to Reproduce
Put Pega under heavy load, then review alert log file.
Root Cause
Working as intended. The alert logger will drop alerts if the buffer is full to prevent possible performance issues.
Resolution
If the system must have all alerts written, even at the cost of slowdown, perform the following local-change:
Set parameter "blocking" in prlogging.xml to "true".
This can cause processing to pause while AES sends alerts, so ensure to set it back to false after running the test. This setting should ensure that, if the buffer is full, AES will wait instead of dropping messages. With that setting on false, AES will drop messages if the buffer is full.
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.