Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Some data table records do not display when viewing the records

SA-51784

Summary



When viewing records in a particular data table, some records are missing. However, on applying a filter and canceling it, all the records display.


Error Messages



Not Applicable


Steps to Reproduce


 
  1. Open the data table and click the Records tab. Some records do not display.
  2. Enter a filter value and click the magnifying glass icon.
  3. Delete the filter value and tab out of the filter field. All the records display.


Root Cause



The issue occurred because an 'is null' condition was set on the report definition associated with the data table. The 'is null' condition was implemented by the system only before the filter was applied and not after the filter was removed.


Resolution



Perform the following local-change:

Remove the 'is null' condition from the filter on the Query tab of the DataTableEditorReport definition rule.



 

Published July 23, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us