Support Article
Some work objects in a workbasket are not displayed in bulk proc
SA-18695
Summary
Some of the work objects are not displayed in bulk processing list during bulk transfer.
The issue is sporadic in nature. NewQueryResultsPage page is generated at run time to store the items in the workbasket eligible for transfer.
Existing values are cleared first. Based on boolean conditions the values are fetched from DB and the page is populated.
Error Messages
(PegaRULES.log)
Cannot open the requested instance '': class or class group" does not exist
Class <blank> does not exist
There is no error message in the UI.
In tracer, Step 3 in getBulkProcessContent is failed with message "Class does not exist"
Steps to Reproduce
1. Confirm number of work objects in a workbasket.
2. Option > Bulk Processing.
3. Choose transfer from workbasket (specify the workbasket you checked at step 1).
4. See the number of work objects.
Root Cause
A defect or configuration issue in the operating environment:
1. Some flow actions had this checked 'Disqualify this action from bulk processing' - That was unchecked.
2. Invalid page is getting passed while invoking checkActionWhens to check when for showing assignments list.
Resolution
Perform the following changes:
1. uncheck 'Disqualify this action from bulk processing'
2. Apply HFix-25587
Published January 30, 2016 - Updated October 8, 2020
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