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Support Article

Sporadic OOM-based crashes rendering application unusuable

SA-424

Summary



Users intermittantly experience login failures.  When this occurs, existing users already logged into the system experience a "hang" (stop) of their requestors.

Error Messages



Users logging in simply see a "hang" of the login process - no errors reported on screen.  Users logged into the system and previously working see their sessions hang.  Users dont report any errors on the screen.

Pega logfile analysis reveals:

1) Multiple Thread Dumps

2) The following out of memory error:


Out of memory exception caught in agent queue: XXLFP #0: XX-Int-YYY-Notify.InitiateSomeService
java.lang.OutOfMemoryError
 at
java.lang.Object
.
clone
(Native Method)

Steps to Reproduce



The customer has found no specific set of steps that cause this condition; however, customer indicates that this condition has been intermittantly occurring within three days of shutdown/restart of their PRPC instances.

Root Cause



The root cause was found to be a known defect in the IBM J9 JVM. This defect is discussed here:

Native OutOfMemory problems are a known problem with certain versions of the IBM J9 JVM for AIX and other Unix/Linux 
operating systems, and IBM has provided several important updates to correct this issue. SR11 (Service Release 11) of the IBM J9 JVM includes a critical fix for classloader static native memory allocations, and this key importance to your system.

Resolution



Per the description above, the solution to this SR is to obtain an updated IBM J9 JVM update kit for WebSphere, and apply the update.

Published March 17, 2016 - Updated December 2, 2021

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