Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

SSL/TLS version conflict after update

SA-36187

Summary



After developers updated from Pega 7.1.7 to Pega 7.2.2, user encountered a TLS Version mismatch issue which caused all SOAP service calls to fail.


Error Messages



Peer not authenticated


Steps to Reproduce



Update from Pega 7.1.7 to 7.2.2.


Root Cause



A software use or operation error.

The "Lowest allowable SSL/TLS version" control on the Advanced tab of service rules allows you to select the appropriate TLS version for your environment.

In this case a lower version than TLS 1.2 was needed, and 1.2 is the default in Pega 7.2.2.


Resolution



Here’s the explanation for the reported behavior:

​The default TLS version has changed to TLS 1.2, however this can be controlled from the "Lowest allowable SSL/TLS version" control on the Advanced tab of a service rule.

Suggest Edit

Published April 24, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us