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Support Article

Standard agent processing error

SA-28035

Summary



A service is used to create claim and dispute cases. Queue-For-Agent step is used in one of the activities to resume the flow and add additional data to the cases. Sometimes, the queue item fails with an error.

Error Messages



Unable to open an instance using the given inputs: ORG-WORK C-123

Steps to Reproduce

  1. Create a service that creates work objects.
  2. Use the Queue-For-Agent method in one of the service activities to queue the case for further processing by an agent.

Root Cause



The error will occur if the agent tries to process the item before the work object is committed.

Resolution



Perform the following local-change:
Select the Deferred option on the Queue-For-Agent step, so that the queue item will not be created until the next commit.

Published September 23, 2016 - Updated October 8, 2020

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