Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Starting flows are not updated when importing rules

SA-37321

Summary



The starting flow labels are not updated when migrated to another environment.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a starting flow and import the flow in another environment.
  2. Confirm the label displays correctly in the New menu in both environments.
  3. Save a copy of the flow in a higher ruleset version and change the flow label.
  4. Import the new flow version in another environment. The new environment still displays the original flow label; however, if you run the flow the proper version is executed.


Root Cause



A defect in Pegasystems’ code or rules.

Resolution



Apply HFix-34106.

The PopulateStartingFlowsForApplication and PopulateStartingFlowsByWorkPool activities can be run to update the data instances with the new flow names until the hotfix can be installed to address the underlying issue.

Published May 15, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us