Support Article
Submit dispute service fails for mandatory field which is missed
SA-53738
Summary
The Submit dispute service fails for a mandatory field which is missed. The system does not display the question 'Provide details on why associated transactions are invalid?' even though the user selects transaction types other than credit. The ExplanationOfCreditPresented field is mandatory is no credit is selected when processing associated transactions.
Error Messages
Not Applicable.
Steps to Reproduce
- Log in to the application
- Select Associate Transaction
- Select Credit Transaction. The question, 'Provide details on why associated transactions are invalid', does not display. This is expected as justification to Visa is not required is a credit transaction is selected
- Select Auth transaction or any other transaction other than credit. The question, 'Provide details on why associated transactions are invalid', does not display. In this case, the user must provide justification to Visa if a credit transaction is not selected
- Run the case. The Submit dispute service call fails
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Apply HFix-41959.
Tags:
Published July 23, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.