Support Article
Subscription Microsite Not Working
SA-33636
Summary
Developer performed below steps for Subscription Microsite:
1) Create an email treatment with a link which will be configured with Subscription Microsite.
2) Configure an offer flow with above email treatment.
3) Create an outbound campaign with a list segment and offer flow.
4) After getting email when clicked on the link, but no customers found on screen.
But It should show subscription preferences and confirmation screen.
Error Messages
No error message but no customers found on screen.
Steps to Reproduce
1) Create an email treatment with a link which will be configured with Subscription Microsite.
2) Configure an offer flow with above email treatment.
3) Create an outbound campaign with a list segment and offer flow.
4) After getting email when clicked on the link, and no customers data was found on screen.
Root Cause
User context was not set. It was referring to Out-of-the-box (OOTB) customer class.
Resolution
Customer Page property reference for PegaMKT-Work-Microsite should be updated to reference custom customer class.
In addition to that following data flow and data set will have affect on customer context which is set in the microsite which should be updated to your custom application referring to custom customer class:
- Data flow
- CustomerData and SingleCustomerData
- Data sets
- Customer
- CustomerDDS
- CustomerNoPartitioning
Published August 23, 2017 - Updated December 2, 2021
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