Support Article

Subscription url button in doesn't work

SA-36662

Summary



After configuring Subscription URL according to this guide:
http://pegasystems2.http.internapcdn.net/pegasystems2/marketing/C-727-StudentGuide.pdf

The resulting link does not work.


Error Messages



Not Applicable


Steps to Reproduce



Screenshots are attached in document.
  1. Create Email treatment as follow 153 in http://pegasystems2.http.internapcdn.net/pegasystems2/marketing/C-727-StudentGuide.pdf
  2. Create new Email Treatment
  3. Add button "Open External URL" with "track offer data" (sceenshot1) and link "http://pegadev02.ahp.local:8080/MS/index.html?Site=Subscription" based on guide
  4. Sent email to user
  5. Click button
  6. window will open with different url than presentation (sceenshot2)


Root Cause



An issue in the custom application code or rules
This problem is only seen on his environment within IE. Chrome worked as expected.

On further review it appears that this system had its IE security setting "Allow META REFRESH" disabled. This will prevent the PORE service redirecting the user to the microsite after it has tracked the users click through.
Enabling this option will resolve this problem.

Resolution



Solution #1:

Enabling IE security setting "Allow META REFRESH" will resolve this problem.

Solution #2:

If this security option needs to be set, then the user will need to be given the option to manually progress to the microsite. This can be done by updating the section

PegaMKT-Work-Offer RedirectStaticSample

Update the body to include the following text

<body>
If you are not redirected automatically, please click <a href="https://community.pega.com/%3C%25%3Ddestination.toString%28%29%25%3E">here</a>.
</body>

Published April 18, 2017 - Updated April 25, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.