Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Survey questions do not display after upgrade to Pega 7

SA-2045

Summary



The survey questions are not displaying after upgrading to Pega 7. You performed a Revalidate and Save on the survey rules, and the questions displayed but did not follow the 'Other Questions Display Logic' that was specified.

Error Messages



No error messages

Steps to Reproduce



Run process to start survey.

Root Cause



The root cause of this problem is an error/omission in the product documentation.  The Revalidate and Save tool needs to be run to the update the survey rules after the migration and the 'Other Questions Display Logic' was deprecated in a previous release of the product due to conflicts with the 'Curent Question Display Logic'.

Resolution



Run the Revalidate and Save tool for the Rule-PegaQ-* rules in your ruleset.  For the display logic, use the 'Current Question Display Logic' instead of the 'Other Questions Display Logic', which has been deprecated.
 
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us