Support Article
Switching accounts throws errors in service/remote case context
SA-20703
Summary
User has recently upgraded from PRPC 6.3sp1 to PRPC 7.1.8 with CS 7.1.4 and FCM 7.1. On 6.3, they are allowed to switch between / change accounts and create service cases for that account. After upgrade, on Pega 7, switching accounts throws errors in service/remote case context. We see an endless busy indicator and errors on the tracer.
Error Messages
Endless busy indicator. Data source errors on tracer
Steps to Reproduce
- Launch interaction portal.
- Launch interaction.
- Select account and create service case for account.
- While in service case context, try changing account and notice the errors.
Root Cause
- This is a backwards compatibility defect in Pegasystems’ code or rules.
- On 6.3, a CSR is allowed to change accounts both while in interaction and service case context.
- On CS 7, a CSR is not allowed to change the context (eg: changing the account number) while service case is in progress. This is by design to maintain the same context for the current “in progress” processes. Hence, even in sample application that Pega Customer Service ships OOTB, the account drop down would be in read-only format when a service case is in progress. That said, when the CSR wraps the service case, the interaction driver screen is displayed from where the accounts can be changed again.
- In Interaction Portal, Pega displays composite data (360 view) even when a service case in progress so that CSR can better service the customer during interaction (CSR need not make additional clicks to see the details on composite).
- This can be seen on CS 7.1 by logging in as CASysAdmin.
- To accommodate this recommendation, the Accounts dropdown should be made read-only while the service case in progress. For design, the OOTB CPMAccountsData section can be referred.
Resolution
Pega CS 7.1 does not allow the CSR to change/switch accounts while a service case is in progress. This is done by design and intentionally so that the service case context is not lost and so that the CSR can better service the customer during interaction (need not make additional clicks to see the details on composite).
The dropdown for changing the Accounts should be made read-only while the service case is in progress. For design, the OOTB CPMAccountsData section can be referred.
Published March 12, 2016 - Updated December 2, 2021
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