Support Article
Sync Failed error occurs on attaching PNG files in Offline mode
SA-96341
Summary
In a mobile device, Sync Failed error occurs when attaching PNG files in the Offline mode.
Error Messages
SYNC Failed
[ttp-apr-8080-exec-76] [STANDARD] [][] (tionqueue.ActionQueueProcessor) ERROR ip-10-123-0-8|Rest|offlinehttp|DataSync|pzsynchronizationservice659e93e2c8d5308618ab6c53efafdd5b|ANMUJRP9N1VLTPBON3ZQDS51SDM0WHDQGA - ActionProcessor | commitAttachment | Could not find attachment file [SI92uwTEPcnQOGKbk5zBTC609VKHxhZI/U6xMvggFVus1JjMojpDy14mxrACjM1U9.jpg]
[ttp-apr-8080-exec-76] [ STANDARD] [][] (MappingAdder._baseclass.Action) ERROR ip-10-123-0-8|Rest|offlinehttp|DataSync|pzsynchronizationservice659e93e2c8d5308618ab6c53efafdd5b|ANMUJRP9N1VLTPBON3ZQDS51SDM0WHDQGA - Mapping already exists on the server!
Steps to Reproduce
- Log in to the offline enabled mobile application.
- Open a case.
- Attach a file. Sync failed error displays.
- Click Retry. A duplicate file or attachment is attached on completion of the Offline step or assignment (attached with 0 KB size).
Root Cause
A defect in Pegasystems’ code or rules.
Offline synchronization failed after an attachment was added. This was because the PRFile API was configured to synchronize attachments with Repositories to store attachments. However, this incorrectly invoked the Work-.AttachFile activity with a Null attachment InputStream.
Resolution
This feature is implemented in Pega Platform 8.3.2.
Published March 24, 2020 - Updated December 2, 2021
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