Support Article
Sync fails with nullPointerException on creation of a work item
SA-53729
Summary
When creating a temporary case on the Pega Mobile Client (PMC), the sync fails with a NullPointerException in PegaRules.log.
Error Messages
[8443-exec-388] [STANDARD] [ ] [AppRuleSet:01.01.01] (internal.mgmt.Executable) ERROR hostname|127.0.0.1|Rest|offlinehttp|DataSync|pzsynchronizationservice|H520R9YWRVG80CDFUUDEF5SJ16LN3B936
- Exception java.lang.NullPointerException
at com.pegarules.generated.activity.ra_action_pzstoreandforwardprocessitems_208caeccd245972bca20fefbcc3cdb2c
.step5_11_circum0(ra_action_pzstoreandforwardprocessitems_208caeccd245972bca20fefbcc3cdb2c.java:2017) ~[?:?]
at com.pegarules.generated.activity.ra_action_pzstoreandforwardprocessitems_208caeccd245972bca20fefbcc3cdb2c
.step5_0_circum0(ra_action_pzstoreandforwardprocessitems_208caeccd245972bca20fefbcc3cdb2c.java:764) ~[?:?]
at com.pegarules.generated.activity.ra_action_pzstoreandforwardprocessitems_208caeccd245972bca20fefbcc3cdb2c
.perform(ra_action_pzstoreandforwardprocessitems_208caeccd245972bca20fefbcc3cdb2c.java:156) ~[?:?]
Steps to Reproduce
- Log in to the application on a mobile device and create a case.
- Click the connection icon if sync has not occurred.
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Apply HFix-41638.
Published September 12, 2018 - Updated October 8, 2020
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