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Support Article

Synching options b/w Assignment table and SLA table

SA-1584

Summary



A synchronisation problem has occured since migrating from 5.4 sp2 to 6.1 sp2.

The goaltime and deadline times are only updated in the related workbasket/worklist tables but not in the PR_SYS_QUEUE_SLA table in case we made some changes in the Goal and Deadline time on newAssignPage- it worked till 5.4.2 versions but after the migration the existing func is no more working because the PYMINIMUMDATETIMEFORPROCESSING of the SLA table column is not getting synched back from the assignment table.

The problem is the code exists from the earlier vs, and in earlier vs if we only had updated the Goal/Deadline in the assignment table it was sufficient that the trigger point is updated. But, since from 6.1 Pega has introduced the SLA table where they check the pyminimumdatetimeprocessing for the next possible event occurrences it is no more working. In the SLA table it is still pointing to the outdated Goal/deadline time even after the updation.


Error Messages



No error message, unexpected behaviour occurs following upgrade.


Steps to Reproduce



Manually reset Goal/Deadline time from one activity


Root Cause



The root cause of this problem is a defect in customer application code/rules. In order for the users to change the SLA settings, a custom ACTIVITY has been created in their 5.4sp2 system. So of course, because the queuing mechanism has changed on 6.1sp2, the SLA processing wasn't working as expected anymore. 



Resolution



This issue is resolved through the following local change.

There are two options  possible in order to solve this situation.

Option 1
To stop using a custom activity and use the Out-Of-The-Box one called ActionChangeAssignmentSLAprops.

Option 2
Modify their exisitng custom activity and adding the 4 steps to dequeue and enqueue the SLA again.

 

Published January 31, 2016 - Updated October 8, 2020

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