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Support Article

System hangs during startup and unable to connect to server

SA-81454

Summary



After upgrading Pega Platform 7.4 to Pega Platform 8.2.2, Tomcat hangs during startups and users are unable to connect to the server.


Error Messages



Not Applicable


Steps to Reproduce



Not Applicable


Root Cause



When thread dumps are forced during the hang, many threads attempt to borrow objects from the connection pool.

In Tomcat, there are two connection pool types:
  1. JDBC Connection Pool org.apache.tomcat.jdbc.pool 
  2. Apache Commons DBCP
The default Apache Commons DBCP connection pool occasionally caused thread blocks.


Resolution



Perform the following local-change:
  1. Include the factory="org.apache.tomcat.jdbc.pool.DataSourceFactory" setting in Tomcat's context.xml to use the JDBC Connection Pool org.apache.tomcat.jdbc.pool
  2. Clear the Pega Temporary directory and restart the server.

    <Resource name="jdbc/PegaRULES
    auth="Container" 
    type="javax.sql.DataSource"
    factory="org.apache.tomcat.jdbc.pool.DataSourceFactory" 
    driverClassName="oracle.jdbc.OracleDriver
    url="jdbc:oracle:thin:@host:port:my_sid
    username="db_user" 
    password="db_password" 
    maxTotal="100" 
    maxIdle="30" 
    maxWaitMillis="10000"/>

Published August 15, 2019 - Updated December 2, 2021

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