Support Article
Task on left navigation panel disappears
SA-26248
Summary
User adds a task in Pega Customer Service for Communications platform. When user confirms the case creation, task disappears from left navigation panel.
Error Messages
Not Applicable.
Steps to Reproduce
1. Login with credentials cscsysadmin/install.
2. Create a sample case (which is like a task in Pega Customer Service for Communications portal).
3. Launch "Interaction Portal".
4. Create a New case, using path New>Demo Screen Pops>Demo Pop - ABC(or any user).
5. Click on "Add Task" on left navigation panel.
6. A pop up window will appear, Select the task created in step 2.
7. Scroll down and click on "Add Task(s)"(Click on "Done" on warning page, if appears).
8. Observe that the selected task is appearing twice in the left navigation panel, every time it is added.
Root Cause
"D_CPMServiceCaseRecents" data page is responsible for loading recent items in the left navigation panel. When a new case is created and stages/processes is configured, a new harness is created,an entry is made in the "D_CPMServiceCaseRecents" data page. User has not configured any stages or processes in the case, thus directly confirm harness opens and task name gets disappeared from left navigation panel. It's an expected behavior.
Resolution
User must have stages and processes in the case.
Published August 5, 2016 - Updated December 2, 2021
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