Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Test Offer does not work with POR activity

SA-6225

Summary



User has configured NBAM Offer Flow which sends SMS using an external third party API (and does not use NBAM out-of-the-box SendSMS shape) and it receives response. This results into error in log files and it does not read the response.

Error Messages



"Error: No batch output class found for customer id 786 when looked up in the Interaction services"

Steps to Reproduce



Create an Offer Flow with Handoff shape that send SMS to customer using third party API -> then wait for some time -> on ReceiveResponse -> Send another SMS -> Test Offer. When user receives 1st SMS and respond to it, an error appears in the log files.

Root Cause



Test Offer is not designed to work with custom solutions where the POR is being used to take the Offer Flow ahead. Basically Test Offer does not put an entry in the PR_DATA_IH_FACT which can be utilised by POR.

Resolution



The reported behaviour is as per the design of the product.

 

Published January 31, 2016 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us