Support Article
Text Analyzer does not detect categories for some words
SA-57696
Summary
When using Pega Customer Service 7.31 on Pega 7.31, Text Analyzer does not detect categories for some words.
Error Messages
Not Applicable
Steps to Reproduce
- Create a taxonomy.
- Duplicate the categories and add 'Should Words' and 'Must Words'.
- Open any Text Analyzer rule
- Navigate to Actions.
- Select Run.
- Enter some text (representatives or clarification) from the Taxonomy on the Run window.
- Click Run.
Root Cause
A software use or operation error.
The Taxonomy was created incorrectly. Duplicate categories were created in the Taxonomy and Rule-Based Classification was not used for classification reference.
Resolution
Here’s the explanation for the reported behavior:
The rule-based classification model used only the Taxonomy provided.
For the Rule-Based Classification model, the test sentence is classified to a particular category when atleast one 'Should Word' is present in the sentence from all the 'Must Words' (if present in the Taxonomy) that are in the sentence.
Tags:
Published August 24, 2018 - Updated December 2, 2021
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