Support Article
Top Exceptions are showing 0 in production
SA-43392
Summary
When viewing the dashboard in production, user is unable to view the top exceptions.
Error Messages
Not Applicable
Steps to Reproduce
- Logon to PDC and view the production now.
- In the dashboard, no entries are registered for Top Exceptions.
Root Cause
Incorrect configuration was not allowing exceptions to propogate to PDC.
The issue was with PegaAES-Data-Nodes instances. The node Id had uppercase prefix (WEB,UTIL) while the exception messages recieved lowercase prefix (util,web). As a result there was no correlation of exception with node.
Resolution
Change node Ids for the cluster to use lowercase and notice that the exceptions are created.
Tags:
Published December 7, 2017 - Updated October 8, 2020
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