Support Article
Transaction ID not updated for offline mobile user
SA-69219
Summary
Transaction ID mismatch error occurs when an offline mobile user accesses an online case.
Error Messages
This action is not allowed as it is outside the current transaction.
Steps to Reproduce
- Create an offline application with an online case.
- Access this case and perform a Finish assignment.
- Reload the cell.
Root Cause
FinishAssignment response is templatized though the UITemplatingStatus parameter is passed as ‘N’ from the User Interface. The UITemplatingStatus must be obtained using the getRootParamValue API instead of getParamValue.
This does not occur when performed from the same desktop.
The client store is not updated with the latest transaction ID and pega.u.d.url contains the old pzTransactionId.
Resolution
Apply HFix-48074.
Published January 5, 2019 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.