Support Article
Unable to add Node in Search Index Host Node Settings
SA-9050
Summary
Search nodes settings were applied even though search node was added and Submit was clicked under Search landing page in Designer Studio.
Error Messages
Not Applicable
Steps to Reproduce
1. Navigate to Designer Studio > System > Settings > Search.
2. Click Search Index Host Node Setting.
3. Click Add Node.
4. Enter node details.
5. Submit.
6. Click Refresh.
Root Cause
Indexing was not working fbecause the following configurations values were set to false in Dynamic System Settings (DSS):
indexing/distributed/enabled
indexing/distributed/index_enabled
Resolution
Delete records from PR_SYS_STATUSNODES table, set following DSS values to true for enabling distributed indexing, restart Pega7 application, and add the primary node in Search landing page.
indexing/distributed/enabled
indexing/distributed/index_enabled
Published May 16, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.