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Support Article

Unable to bring up the Pega application

SA-20357

Summary



User performed new installation of Pega 7.1.9 on JBoss application server with DB2 as the DB server. System successfully started but when attempting to access the login screen, user gets the below mentioned error.
 

Error Messages



In the browser see this error:

Status fail
Message There has been an issue; please consult your system administrator
Operator ID Unauthenticated or not available
Requestor ID H63B1A93413E8A773FC9F43DA5460A750 – (you will find different requester in the logs but the principle is the same)
Timestamp Wed Feb 24 13:29:05 EST 2016
Engine Version PegaRULES 7.10 ML9 (coreAssemblyCached_719_730)

In the log file see this error:

2016-02-26 00:00:03,140 [-threads-1375761367)] [  STANDARD] [                    ] [        PegaDM:07.10] (l.library.LibraryMetadataCache) ERROR   - Problem invoking function: pega_decisionengine_strategyutils.pxLoadSettings--(PublicAPI)
java.lang.ClassNotFoundException: com.pegarules.generated.pxLoadSettings_071017_KwCOkgJFClTu6_698Aajzg
    at com.pega.pegarules.internal.bootstrap.phase2.PRBaseLoader.findClass(PRBaseLoader.java:312)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at com.pega.pegarules.internal.bootstrap.phase2.PRBaseLoader.loadClass(PRBaseLoader.java:237)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    at com.pega.pegarules.bootstrap.loader.PRAppLoader.loadClass(PRAppLoader.java:772)
    at com.pega.pegarules.bootstrap.loader.PRAppLoader.loadClass(PRAppLoader.java:649)
    at com.pega.pegarules.exec.internal.util.classloader.PRClassLoaderDB.loadClass(PRClassLoaderDB.java:1069)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

Steps to Reproduce



Open up a browser and type in http://localhost:8110/prweb/PRServlet


Root Cause



A defect or configuration issue in the operating environment.

Resolution



Make the following change to the operating environment: 

Clear the 
PegaRULES_Extract_Marker.txt and restart the system to resolve the issue.

 

Published March 1, 2016 - Updated October 8, 2020

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