Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to connect to Agile Studio

SA-80855

Summary

Unable to connect to Agile Studio.


Error Messages

Enter a valid Agile Studio URL.


Steps to Reproduce

  1. Open the Application Definition of the target application
  2. Select the 'Integration & security' tab
  3. Click the 'Configure integration' button in the 'Agile Workbench integration'.
  4. Click Pega Agile Studio.
  5. Paste the Agile Studio URL in the field.
  6. Click the Connect button.


Root Cause



An issue in the custom application code or rules.
The Authorization profile was incorrect.



Resolution



Perform the following local-change: 

1. In the URL, use v1 instead of v2 since only v1 is supported.

For example: https://YOURURL/prweb/PRRestService/api/v1

2. Tracer Error: The server responded with an HTTP 401 code, indicating an authorization problem. 

The body of the service's response, which is set up for mapping in the Connector rule, is empty for this service call.

Verify the Agile studio Authorization profile, and enter the correct username and password.
Suggest Edit

Published August 15, 2019 - Updated December 2, 2021

Did you find this content helpful? Yes No

50% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us