Support Article

Unable to connect to Vendor's WebService URL

SA-85933

Summary



The 'URL not reachable' error occurs when migrating the SOAP endpoint to a different system with new certificates. The SSLPeerUnverifiedException error is generated in the log.


Error Messages



com.pega.pegarules.pub.services.ConnectorException: Caught unhandled exception: javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated 
...
at java.lang.Thread.run(Thread.java:662) 
Caused by: javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated 
...
Caused by: javax.net.ssl.SSLException: java.lang.RuntimeException: Could not generate DH keypair 
    at com.sun.net.ssl.internal.ssl.Alerts.getSSLException(Alerts.java:190)



Steps to Reproduce



Perform a Test connect from the Connect-SOAP rule.


Root Cause



A defect or configuration issue in the operating environment.
The client environment connecting to the endpoint was missing support for the Server Name Indication.



Resolution



Perform the following local-change:
  1. Upgrade to JDK 1.7.
  2. Import the Certificate chain of the endpoint in a .jks type TrustStore file and use in the WS-Security profile TrustStore section.

Published August 5, 2019 — Updated August 15, 2019

Have a question? Get answers now.

Visit the Pega Support Community to ask questions, engage in discussions, and help others.