Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to convert lead in BSB Mode

SA-37034

Summary



When using Pega Sales Automation in Business to Business (B2B) selling mode and converting leads to contacts, an error occurs.

The process is throwing a validation error because it is trying to validate the creation of an individual account.

However, in a B2B application, no creation of an individual account should happen.

Error Messages



No error message but validation fails when attempting to create the individual account.


Steps to Reproduce



1) Create Lead (In B2B Application).
2) Convert Lead to Contact (In B2B Application).


Root Cause



The validation logic in the rules did not take this circumstance into account.

Resolution



Apply HFix-33485.

Published May 15, 2017 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us