Support Article
Unable to convert lead in BSB Mode
SA-37034
Summary
When using Pega Sales Automation in Business to Business (B2B) selling mode and converting leads to contacts, an error occurs.
The process is throwing a validation error because it is trying to validate the creation of an individual account.
However, in a B2B application, no creation of an individual account should happen.
Error Messages
No error message but validation fails when attempting to create the individual account.
Steps to Reproduce
1) Create Lead (In B2B Application).
2) Convert Lead to Contact (In B2B Application).
Root Cause
The validation logic in the rules did not take this circumstance into account.
Resolution
Apply HFix-33485.
Published May 15, 2017 - Updated December 2, 2021
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