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Support Article

Unable to create a case through search portal results

SA-31357

Summary



When the user tries to create a case using an existing transaction, system throws a null pointer exception on the screen and the case does not get created.



Error Messages



 

Root Cause



On tracing, found the exception on the clipboard: failing at RDB-List step , where a connect-sql rule has been written , in which a procedure has been written to connect to external DB . TestConnectivity of Connect-SQl is proper, but the class connectivity where this connect-sql rule is present is failing.

This is because, while finding schema name(getSchemaName()) , it is getting null .

 

Resolution

  1. Note the user that has been configured in the webSphere server
  2. Login with the same user into the database
  3. Run the query select schema_name()
  4. If it returns null, need to associate the schema to that particular user
 

 

Suggest Edit

Published December 14, 2016 - Updated October 8, 2020

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