Support Article
Unable to create cases
SA-31226
Summary
After upgrading to Pega Platform 7.2.1, when attempting to create a case from Designer Studio an error is seen on screen and the case creation does not complete.
Error Messages
Error in logs:
Caused by: java.lang.AbstractMethodError: org.apache.tomcat.dbcp.dbcp.DelegatingCallableStatement.setNString(ILjava/lang/String;)V
at com.pega.pegarules.data.internal.store.DatabasePreparedStatementImpl.setNString(DatabasePreparedStatementImpl.java:1374)
at com.pega.pegarules.data.internal.access.oracle.SQLGeneratorOracle.setNStringOnPreparedStatement(SQLGeneratorOracle.java:1613)
at com.pega.pegarules.data.internal.access.SQLGenerator.callStoredProc(SQLGenerator.java:3450)
...
Steps to Reproduce
- Open Designer Studios as the out of the box operator [email protected].
- Click the Create button, highlight the Case menu option and click the desired case type to create.
- Observe the on screen error.
Root Cause
A defect or configuration issue in the operating environment: The version of Tomcat in use (Tomcat 6) isn't complaint with Pega Platform 7.2.1.
Resolution
Make the following change to the operating environment:
Upgrade to Tomcat version 7 or 8.
Published December 14, 2016 - Updated October 8, 2020
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