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Support Article

Unable to create new Test Case rule

SA-41056

Summary



Error on enabling AutomatedTesting (for rules), performing Save Test Case (when running the rule), and clicking the Create test case from the Quick Create modal dialog.


Error Messages

Error:**Quick CreateERROR Save failed<br>**Rule Documentation is required--Full Description and Usage


Steps to Reproduce



1. Navigate to Activity > Test Case > click the Record New Test Case button
2. Execute the rule and click the Save Test Case button (a pop-up window appears to create new test case)
3. Enter the details in new Test Case rule
4. Click the Create button



Root Cause

When creating a new rule, Pega checks for Warnings present on the rule and creates the rule. The CheckForCustomWarnings rule, was customized to validate class rules, was blocking the creation of rules.


Resolution

Perform the below local-change to make changes in the custom rule:

Remove the validations on the Warning checks for the class rules.



Published September 29, 2017 - Updated October 8, 2020

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