Support Article
Unable to deserialize Catalog error msg in updatemanager
SA-37999
Summary
User is trying to upload the CATALOG.ZIP file in the update manager to perform a system scan.
After the upload is completed from a local system user clicks the Scan button and few moments the below appears on screen:
Error Messages
Unable to desrialize Catalog ** see log for more details
The below error appears in the PegaRULES.log file:
PegaRULES:07.10] (t_HotfixManager_Scanner.Action) ERROR - Unable to deserialize Catalog
com.pega.pegarules.pub.PRException: Object deserialization failed
com.pega.pegarules.pub.PRException: Object deserialization failed
at com.pega.pegarules.updatemanager.util.MiscUtils.deserializeObject(MiscUtils.java:472)
at com.pega.pegarules.updatemanager.util.MiscUtils.deSerializeFromFile(MiscUtils.java:306)
at com.pega.pegarules.updatemanager.catalogue.CatalogUtils.processCatalogZip(CatalogUtils.java:255)
at com.pega.pegarules.updatemanager.catalogue.CatalogUtils.processCatalogZip(CatalogUtils.java:214)
Caused by: java.lang.OutOfMemoryError: Java heap space
at java.lang.StringCoding$StringEncoder.encode(StringCoding.java:300)
at java.lang.StringCoding.encode(StringCoding.java:344)
Steps to Reproduce
- Go to Hotfix manager.
- Click to scan system.
- Select a catalog.
- Click to scan.
Root Cause
This is a Java out of memory exception.
The issue happened due to insuffiecient memory size specified in the JVM arguments.
Resolution
Increase the memory allocation using the -Xms and -Xmx arguments to a sufficiently large value. This resolves the issue.
Published June 15, 2017 - Updated October 8, 2020
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