Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to determine the DB2 database for Smart Dispute 7.1

SA-2282

Summary



Admin upgraded to Pega 7.1.5 on db2zos and is attempting to install Smart Dispute framework.

Started the import of the Smart Dispute rules into the database but is seeing the following messages on the screen



Error Messages



Unable to determine the db2 database name where new tables will be stored in Data-Admin-DB-Name PegaRULES
Please set the following setting: database/databases/PegaRULES/db2zos/dbname


Steps to Reproduce



Upgrade to PRPC 7.1.5 on db2zos and try to import the RAP file that comes with the Smart Dispute framework.


Root Cause



The root cause of this problem is an error in product documentation. In the install guide references setting this db2zos/dbname for the import tool to use. It says it is optional but without this set the import tool will not generate the DDL needed for a framework import of RAP file. There is no reference to this setting in the Upgrade Guide.


11. (optional) Set database DB2 z/OS database name for schema import. For DB2 z/OS, in order to

import new database objects via the import wizard, the following configuration settings need to be

set in order to identify the name of the database to PRPC:

  • For Binding Identifier, enter PegaDataDB2zosDBName.

  • For Name in the namespace relative to lookup name prefix, enter the string:

    prconfig/database/databases/PegaDATA/db2zos/dbname

  • For String Value, enter the name of the DB2 z/OS database as specified to the installer as the #DBNAME substitution parameter.


  •  
This setting will associate the DB2 z/OS database name to the PegaDATA Data-Admin-DB-Name instance. This needs to be set so that the resources associated to the new objects will be allocated from the appropriate resource pools and not from the DB2 subsystem internal resource pools.


Resolution



This issue is resolved through the following local change: Admin set the database DB2 z/OS database name as outlined in the Installation Guide.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us