Support Article
Unable to execute Extract rule
SA-1657
Summary
Manually running a Business Intelligence Exchange (BIX) extract rule produces "No Instance found in the database" error on screen and a RuleNotFoundException in the logs.
Error Messages
No Instance found in the database
Steps to Reproduce
Execute BIX extract rule.
Root Cause
The BIX extraction uses the default application of the operator for the batch processing instead of current application context.
Resolution
This issue is resolved through the following local change: Set the BIX application as the default application for the operator running the extract manually.
Published January 31, 2016 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.