Support Article
Unable to locate original subject in DSN
SA-58066
Summary
Unable to locate the original subject in Delivery Status Notification (DSN) and the original thread topic headers.
Error Messages
Not Applicable
Steps to Reproduce
- Open the generated email listener.
- On the Process tab, select the Process DSN option.
- Open the generated service rule and select the Request tab.
- Add a data mapping row in the Message Header section for the thread-topic message header.
- Map it to parseThreadTopicHeader Rule-Utility-Function and enter the .pyInboundEmail property as the Map To Key.
- Save the listener.
Root Cause
DSN processing depends on the mail server.
Resolution
Here's the explanation for the reported behavior:
In DSN, thread-topic mapping depends completely on the email server.
In case of Gmail, the thread-topic has the classname and the work-ID; while in Outlook, the thread-topic is just the subject of the failed email. It depends on how the email server perceives and processes the DSN message.
Published August 24, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.