Support Article
Unable to log into mobile: Cannot log in due application error
SA-31819
Summary
Unable to log into custom mobile application with credentials.
Error Messages
On screen: Cannot log in due application error. See logs
On logs: Cannot set property 'busyIndInterval' of null
Steps to Reproduce
Log into the mobile app with the credentials.
Root Cause
An issue in the custom application code or rules:
pega.u.d.gBusyInd.busyIndInterval was null and an If condition was missing. Hence, Cannot set property 'busyIndInterval' of null error occurred.
Resolution
Perform the following local-change:
Add If condition in userworkform script tag to check whether object 'pega.u.d.gBusy' is available.
<script type="text/javascript">
pega.u.d.busyIndInterval = 0;
if(pega.u.d.gBusy)
pega.u.d.gBusyInd.busyIndInterval=0;
</script>
Published January 5, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.