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Support Article

Unable to Login after application Imports completed

SA-50523

Summary



User is unable to complete the installation of "Pega Customer Services for Communications" (Media File: "115710_PCRMC731.zip\PegaCRMC_731.jar") on Pega Customer Service for Communications 7.31.


The progress bar reaches ~95% during the installation, but then the browser stops processing; there is an error in logs (below) and from that point onwards, it is no longer possible to login into Pega application.


The inability to login persists even after PRPC is restarted.


Error Messages



[...]
Caused by: com.pega.pegarules.pub.context.InvalidConfigurationException: No such Access Group: PegaCRM:Unauthenticated for thread STANDARD
at com.pega.pegarules.session.internal.authorization.context.GlobalContextCache.getBasicApplicationContext(GlobalContextCache.java:428) ~[prprivate.jar:?]
[...]


On-screen error, after pressing Login:

"There has been an issue; please consult your system administrator"

Steps to Reproduce



Import 115710_PCRMC731 – PegaCRMC_731.jar on a Pega 7.31 system which doesn't have the pre-requisite "Pega Customer Service and Pega Sales Automation" installed on it.


Root Cause



The Pega Customer Services for Communications Application should only be installed on a system where "Pega Customer Service and Pega Sales Automation" (115672_PCRM7.31.zip) has already been installed.

This pre-requisite is documented in the manual "Pega Customer Service for Communications INSTALLATION GUIDE 7.31", page 4, under "Other Requirements".

https://pdn.pega.com/documents/pega-customer-service-communications-731-installation-guide


Resolution



The installation of the "Pega Customer Services for Communications" alters the 'Requestor Types' (instances of the PRPC Class "Data-Admin-Requestor") such that they reference the Access Group "PegaCRM:Unauthenticated".

This Access Group is not present unless the pre-requisite ("Pega Customer Service and Pega Sales Automation") has already been installed.

Since the 'Requestor Type' record for 'Browser' is used during authentication/login, the log process will not function if a non-existent Access Group is referenced.

Should this scenario occur, recover Login Functionality by following this Support Article:

https://pdn.pega.com/support-articles/initializationfailederror-log-file-during-prpc-start


Published April 11, 2018 - Updated December 2, 2021

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