Support Article
Unable to open case post-upgrade(PRPC 6.3 SP1 to Pega 7.1.7)
SA-8898
Summary
Post upgrade from PRPC 6.3 SP1 to Pega 7.1.7, user is not able click on workbaskets, worklists and any links in the Dashboard page.
If user tries to search for cases, the search results shows up; but when drill-down action is performed such as clicking on the ID, it does not work. This issue occurs only with Internet Explorer, running in Compativility/Quirks Mode.
Error Messages
Message: Object doesn't support this property or method
Message: 'pega.desktop.availableSpaces.length' is null or not an object
Steps to Reproduce
1) Upgrade from PRPC 6.3 SP1 to Pega 7.1.7.
2) Access the Case Worker portal using IE running in Compativility/Quirks Mode.
3) Click on workbasket or worklist and search for a case and try to open cases.
Root Cause
Quirks mode is a mode specific to the IE 6 and old browsers - Pega recommends not to use the quirks mode from Pega 7.1 onwards.
All Pega 7.1 and later versions are supported in standards mode applications only.
Resolution
Run IE in standards mode for Pega 7 or later version. Try another browser for exmaple,Chrome.
Published January 31, 2016 - Updated October 8, 2020
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