Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to process Batch recods within time using advanced agents

SA-2734

Summary



When setting up and testing agents, developers see that agents are running every 30 seconds when they are set to run in shorter intervals.

Error Messages



N/A


Steps to Reproduce

  1. Create agent and set scheule time to 5 sconds
  2. Check SMA, and note that the Interval time shows "Every 30 Seconds".

Root Cause



The "Interval" field on the agent and agent schedule ruleforms is used for setting the "Trigger Interval" for each agent.  There is a prconfig setting, agent/minimumwakeup, that controls the minimum value that can be provided for an agent's Trigger Interval.  This setting has a default value of 30 seconds.  If a Trigger Interval is set on an agent for a shorter amount of time than the agent/minimumwakeup setting, the value of the agent/minimumwakeup setting overrides it.  

Resolution



This issue is resolved through the following local change:

You can adjust the value of the agent/minimumwakeup setting to change this behavior.  Please note the value of the agent/minimumwakeup setting must be at least 5 seconds.

For more information on this setting, please see page 20 of the PRPC Configuration Settings Reference Guide, https://pdn.pega.com/documents/configuration-settings-reference-guide-prpc-5x-prpc-62.
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us