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Support Article

Unable to receive any email after a campaign is run

SA-59075

Summary



Unable to receive any email after a campaign is run. The user has Pega Marketing v7.13 on Pega 7.1.9.


Error Messages



Not Applicable.


Steps to Reproduce



Run a Campaign where an Offer is triggered in which an Email shape is configured to send the email to the user.


Root Cause



A defect in Pegasystems’ code or rules.

The instances of Data-Corr-Email XML has the Account as 'Default' and Status as 'Pending-Delivery'. On checking the records of PR_DATA_CORR_EMAIL, it was observed that the record has the 'Default' value for 'Account' column and 'null' in 'Status' column.

In the class inheritance of the Data-Corr-Email there is another property, 'STATUS', in @baseclass (with a different case). On Obj-Save of Data-Corr-Email records, in the merge query, it attempts to fetch the property 'STATUS' and not the property 'Status'. The XML does not have this property and hence, the 'null' value is inserted in the database column. 



Resolution

Perform the following local-change:

Explicitly map the property ‘Status’ to the database column or if the property is not required in @baseclass, remove the property.



 

Published July 26, 2018 - Updated December 2, 2021

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